Saturday, December 3, 2011

Fix Obtaining IP Address Android WiFi Problem

Recently, I've upgraded my android phone Samsung galaxy ace to new firmware. But after doing this, there are problems arised related to WiFi. Before the firmware upgrade to android 2.3.5, there was no difficulty in connecting WiFi to my mobile as it automatically connects when I switch on WiFi. But the upgrade cuases to show "Obtaining IP Address"  on the WiFi settings page and it never connects.



After searching about this problem on internet, I found that many other people facing the same problem. But at last I found a solution for this problem and going to share here. Here's the solution to Obtaing IP address Wifi problem on android:

The solution is to use a static IP for your WiFi connection, to do this:
  • From your android device, goto Settings > Wireless and networks > WiFi Settings > Click menu button (left) and select advanced.
  • You'll see an option "use static IP" under IP settings section. Enable it and enter the following parameters.
  1. IP address : 192.168.1.253
  2. Gateway:     192.168.1.1
  3. Netmask:      255.255.255.0
  4. Dns1:            8.8.4.4

  • By doing this, you should immediately get connected to your wifi network. I've tested this with my BSNL Teracom Wifi modem.

Let me know if this solves the probelm..

Custom Search

108 comments:

kirollos said...

your the best man it work man help me alt i been trying to fix for almost 2 month thankkkkkkkkkkkkkkkkksssssssssssssssssssss

Al said...

Thanks so much! This has worked for me. Does it work for any wifi source? Like router, hotspot, etc?

Anonymous said...

Ell

Connected great, still no web pages load.

I recently rooted 2.2 not worked ever since help please!

Anonymous said...

Wonderful! THANK YOU!!!

Anonymous said...

Hi,

It doesn't work for 2.3.5, but works for 2.3.6

Aashima Sharma said...

awesome man ...... thanks a lot .

Anonymous said...

thanks man...!!!

Anonymous said...

Wow.. Really great......... Please let me know how do u know this.... Any reference sites....

vijayendran.mca@gmail.com

shahi said...

but still told me when i open gamed hup "application requires working data connection " !!!

Akshay Harlikar said...

thnkx for help and want to know if i can use same static ip address for other wifi networks around us like airport and industry rather than bsnl wifi

Anonymous said...

didnt work liquid metal 2.3.6
thanks for trying

ram said...

no web pages loading

Anonymous said...

It worked thanks a lot. Anbu

Anonymous said...

worked like a miracle on my samsung pop after the gingerbread update...

thanks a lot!!
.snik

Harshal said...

Is your router DHCP turned off?

Harshal said...

Thanks a ton man. It worked on my I9000.

Dalela said...

Tons of Thanx!
I was very puzzled with my new phone Samsung Galaxy R
Your Trick helped me ve...........ry much

Anonymous said...

You are the man! Thanks!

Anonymous said...

Thanks a lot bro. it's helped me to connect my WiFi home network.
your R&D is really appreciated.

Anonymous said...

you sir are a legend, been struggling with this for ages! :D

Anonymous said...

Thanks this helped a lot I got it to work

nick said...

Awesome, i got this chinese crap with 2.3 OS and yeah it worked.

Anonymous said...

It worked. Thanks a lot

Anonymous said...

no load the page .anyone have solved?

Bashar Bhuiyan said...

it is connected but not loading any page.

ramakrishnan said...

gr8. thanxs

Anonymous said...

thankyou so much! ive searched for 2 hours to find a solution

Anonymous said...

Hi,
Since, I got my desire s with 2.3.3 and after upgrading to 2.3.5, there was no solution of my wifi problem. The phone accessed to the net everywhere but home.
I tried yr suggestions and now, I read my fav. sites from the phone after 3 months. Thanks a lot!

Jehan, PK

Anonymous said...

So i did this , and i didnt think it would work because i have a huawei but it did ! :O
thank you majorly , been struggling for 4 months now .

Anonymous said...

This worked like a charm I have been trying to fix it for last 8 hours! THANK YOU SO MUCH!

jaiswal said...

thanks buddy .. its work for me

nikifor255 said...

same problem with web pages and stuff

John said...

Your solution works - to some extend. Phone (mytouch 4G - android 2.2.1) connects to the network, but no internet or page load. Here is the reason why (in my case, and sharing with you guys):

Android connects to a router even if the password is wrong.

Android will NOT tell you that the password you entered is wrong.

Android keeps saying obtaining an IP address even if the password is wrong.

I realized that one digit in the password I entered was wrong (only after the person, I share the wireless connection with, told me)

SO the solution for some of you may be finding out the right password. Double check that what you are typing is right.

Hope it works for you.
Good luck.

John said...

By the way, yours was an elegant solution.
Thanks for sharing.

Hussain said...

Why does everyone keep posting this method as a "solution"? This should be marked as a work around instead. The reason being, your Wifi - and mine as well - is not issuing an IP. This method doesn't make it issue one, just bypasses the DHCP failure issue altogether.

OTOH, assigning a static IP brings a new problem: What happens when you move to a new Wifi area? In a normal day, you'd have to reconfigure your phone 4/5 times.

Abdul said...

Fantastic, it worked for me. thanks!

Anonymous said...

By the Grace of Allah the mighty God. You,ve helped me solved my problem.

For the past one week It has been sleepless night for me going through the internet trying to solve my problem. It all started with my ZTE V9 light which can't obtain IP address from my ZTE Ar450 EVDO router, no doubt I don't have this problem with other brand of routers.

Thanks again. Allow me to share your findings with others who may have the same problem.
God Bless You!

Arun said...

i'm arun...same mobile i'm using...i've used that wt ur telling in the review..it gets connected...the page doesn't load.......

Arun said...

i've followed the steps wt ur telling..the same galaxy ace is only using.....wifi connect....but the apps did not open..it ask ..."there was a plm with the network........

vinod gohri said...

vinod gohri

its working thanks....

Anonymous said...

This worked like a charm. I had been struggling with this problem for months after I factory wiped my Samsung Galaxy S. Now I have WIFI connection back! Thank you so much.. cheers! LM

Anonymous said...

Thanks a lot ! It totally worked - I called MTNL people for 4 days and they are so dumb. Thanks a lot :)

Anonymous said...

I tried your solution. Now the WIFI status is connected. but it is not connnecting to internet. It is giving the error as "unable to connect to the server". I bought my Samsung Galaxy ACE just a week ago.... and My modem is BSNL wifi modem...... Please tell me what can I do for this.

Anonymous said...

I tried your solution. Now the WIFI status is connected. but it is not connnecting to internet. It is giving the error as "unable to connect to the server". I bought my Samsung Galaxy ACE just a week ago.... and My modem is BSNL wifi modem(DNA-A211-I) Please tell me what can I do for this.
ANIL

Ret said...

I agree with Hussain:

"Why does everyone keep posting this method as a "solution"? This should be marked as a work around instead. The reason being, your Wifi - and mine as well - is not issuing an IP. This method doesn't make it issue one, just bypasses the DHCP failure issue altogether.

OTOH, assigning a static IP brings a new problem: What happens when you move to a new Wifi area? In a normal day, you'd have to reconfigure your phone 4/5 times."

Anonymous said...

karan hey i m spidigo user.. nd i hv get same error .. what i do ??? plz tell me

saurabh said...

Whoa mann.
thanx a lot.
Last time i had to roll back 2 2.3.4 after encountering this problem in 2.3.5 version.
This time i upgraded to 2.3.6 and faced the same problem but m glad dat some one came up with such an easy yet effective solution.
Saurabh,bsnl,ghaziabad

Alabhya Dhamija said...

DUDE you just rock.. awesome.. it solved all my probs..:)

cool work..:D

royDK said...

GENIOUS

Atu said...

Thanks Man! You rock:)
U've made my day!!!!!

Anonymous said...

Wow thanks so much!

Aakar Anil said...

Thanks man!

Joan Brady said...

Sweeeeet :)

Anonymous said...

dude thanks a million.works perfectly on my galaxy note.

Upendra said...

Amazing! I had not problems to connect with my home wifi but had problems to connect with my office wifi and it's fixed now!

Fatush7 said...

now it connects but... still doesnt load pages or even the android market

Velmurugan said...

great.it worrikg

Anonymous said...

Hi,

Am using Galaxy s2.when am attempt to connect Wifi in my home its shows connected.but i cant access any thing.same as its when am using wifi in my friend home its connected and its working all application.

What is the solution for this !!!!!!!!!!

if anyone knows solution let me !!!!!!!!!

Tosicx said...

It worked!!! I got extremely tired of this so i googled for a while and found you!! You are the best, thank you sooooooo much !!!!!

Anonymous said...

man it worked!thank you so much,i was desperate to find the answer and i did thanks to you!you're the man

Tom said...

To those who get it to connect and then have no internet...go into your setting and reconnect to the wifi after you do the stuff above...I had the same problem...full bars and no internet. I went into setting and saw the network as available but not connected...clicked on it and it sprang to life.

Anonymous said...

Well with Galaxy Tab 7.0 plus there's a problem. I can't Set it to static because the format used by Android 3.2 is slightly different from Android 2.2. There's no place to key in the Gateway code and the Netmask code. How to go around it ?

Anonymous said...

I've got this problem to on my GII which under ICS update doesn't appear to give the option to set a static IP.

My Galaxy worked perfectly prior to the ICS update and didn't have this wifi problem.

Anonymous said...

IT works, but its not green! no connection, connected, but no connection

Anonymous said...

thanks dude! that was really very helpful!!! :)

Anonymous said...

OMG I love you! This worked!!!!!!!!
Even though I'm in Venezuela, it worked!! it worked!!! :D Thanks a lot!!!

High Speed Internet said...

Man, I also had the same problem. Thanks for sharing how you solved this!

Anonymous said...

awesome.... superb..no words to thank u....

Anonymous said...

i love it... man
you are cooooollll....

Jony Saha said...

i have upgraded to Ice Cream Sandwitch...this DNS option is not coming now..any idea.

Anonymous said...

Thanks!

Shakeeb Ahmed said...

hi frnds i have samsung galaxy ace plus i have problem obtaining address during the wifi connect
but i reset setitng than i have same problem when checking username availability in android welcome page setup plz plz frnd let me know any soluation pls thanks
my mail id shakeebahmed77@gmail.com

Anonymous said...

Thanks a ton ! worked like a dream

Anonymous said...

thanks man.
it worked perfectly for my xperia mini pro :)

Anonymous said...

it worked. thank you soo much!

Anonymous said...

I agree with Hussain. This is not a solution, just a workaround. A solution must be useful in every situation. If you really know about IP addresses and how they work to connect to the net you can realize the problem is still there.

Anonymous said...

I LOVE YOU MAN ! <3

Arun Raju said...

How have you setup your router? What type of Security type (WEP, WPA) and Cipher type have you configured?

Anonymous said...

Pls what do l put in dns 2? Cause it is still not connecting

Anonymous said...

i am Sam sung Galaxy 1 user my phone is not showing any wifi in range. i tried this one but it does not work for me what should i do to fix this problem. please help me.

Anonymous said...

Thanks, this worked for me with my HTC Wildfire S on the MetroPCS network.
If this is such a common problem why isn't anyone doing anything to fix it? If this was a Windows OS I could understand the problem being ignored, but Android is a Google product and Google seems to want their products to work properly.

Rawz said...

It connects but the net is still not working. What networks does this setting work for?

Anonymous said...

thanks,it worked....

Anonymous said...

Thanks ALL !
my problem was simply WRONG PASSWORD !!

thanks john!

Anonymous said...

thnks dude ., it helped

amiarmiess said...

********DOES NOT WORK ? READ THIS FIRST********

YOU MUST DO THIS FIRST ON YOUR DEVICE

From your android device, goto Settings > Wireless and networks > WiFi Settings > Click menu button (left) and select advanced.
You'll see an option "use static IP" under IP settings section. Enable it and enter the following parameters.

IP address : 192.168.1.253
Gateway: 192.168.1.1
Netmask: 255.255.255.0
Dns1: 8.8.4.4

* TRY DISABLES YOUR DEVICE WIFI IF NOT SUCCESSFULLY

AFTER YOU HAVE SETTINGS YOUR DEVICE, DISABLE THE STATIC IP AGAIN AND THEN YOU CAN USE THE WIFI.

Anonymous said...

tq freinds

Anonymous said...

I have 2look 2pad 2LX07-S1 7" with Andriod 4.0 and It is connected to my wifi but I have no acess to internet,right below network it spells Saved,secred with WPA. AND on this tablet there is no option to use static IP. PLEASE HELP ME .:(

Seb.Lefb said...

Greatt. thx alot

darknescrew said...

yo bto .. i help me thx.. but can i ask u..why it still have probelem with page conetion

ashok mallick said...

Hi,

Am using Micromax A56 superphone ninja2.when am attempt to connect Wifi in my office its shows connected.but i cant access any thing.same as its when am using wifi in my friend home its connected and its working all application.

What is the solution for this !!!!!!!!!!

if anyone knows solution let me !!!!!!!!!

Anonymous said...

does anyone solved the problem "loading page" ???

Anonymous said...

it connected to wifi network.but cant load any pages. help me in this .... reply plz..tpamarasekera@gmail.com

Anonymous said...

Htc desire ,android 2.3.3 ,it worked. thank you soo much!

Anonymous said...

bro my problem is my mac address is unavailable...may ip address is un unavailable...my phone is LG L3 E400...can any one help me fix this

dm

Anonymous said...

gits here..it doesnt work for my android 2.3.6. still showing wifi error

Erik Plata said...

thanks alot man

Anonymous said...

Thanks a ton buddy... worked like a charm...

Anonymous said...

hi everyone, just bought a new samsung galaxy win last week, unfortunately when i try to connect my wifi at home its not working, it shows "Secured, Saved", but its not connected, i need your help guys, thanks in advance,

dinesh jaiswal said...

Hi evryony just bougst a new samsung galaxy one manth unfortunatly when i try to Connect my wifi at office its not working it shows secured sevad but is not connect I need your help guys thanks in advance

cyber expert said...

M using xperia ZR and there is no such options pls help

sachin Aggarwal said...

how can i resolve my probelem...i tried al...but all in vain...
and also there is no option for netmask in my phone samsung galaxy grand quatrro

muthu raj said...

Its working.. thank you..

Anonymous said...

I bought MICROMAX A114.. It does not have STATIC IP Address creation provision for WIFI. It keeps saying "Obtaining IP Address", when we tried to connect WIFI automatically. There is no manual way.

Can anybody suggest solution for this.

Anonymous said...

hi it very helpful to me and one more thing to ask that personal username and password also is to connected but it not showing. still no connection?

BRIJ MOHAN SAINI said...

thank you very much .......

Anonymous said...

Yayyyy....finally!!! it worked! Android 2.3.5. Thank you so much!!! really appreciate it!!

Anonymous said...

i used to work for AT&T internet service. When customers would call in with internet or wifi connections issues we would have then set there static connection as ip address192.168.1.254..........Gateway192.168.1.1...........subnet mask255.255.255.0................this is similar to what you have.....i dont have an at&t phone but this worked for me..........your artical is very helpful it actually brought back old memmories

Post a Comment

Please enter your name while commenting.

Related Posts with Thumbnails
 
Free Domain Full RSS - Comments RSS Computer Blogs - BlogCatalog Blog Directory Top Blogs Alitu.com - General Website Directory
Powered by Blogger